Current development on JAMWiki is primarily focused on maintenance rather than new features due to a lack of developer availability. If you are interested in working on JAMWiki please join the jamwiki-devel mailing list.

Comments:JAMWiki 0.7.1

User Roles Problem[edit]

Archived from the Feedback page:

I am trying to use the user roles feature (just the standard one supplied by jamwiki - no external database, ldap etc yet) but i dont seem to be able to add a role to a user. When i use the Search for a user in the Roles page it never finds any user, except the admin user ( which is the user i am logged in as , so maybe is filtering on current user or something). I have upgraded to 0.7.0 so i dont know if this is a bug in the beta - or if i am just doing something wrong (i havent used the user roles before).

This feature seems to be working on jamwiki.org, but it's entirely possible that there may be a bug somewhere - could you let me know the user name you're searching for? Searching for something like "w" or "wrh2" both find my user on jamwiki.org as well as any similar users, so I'd be interested in knowing exactly how to reproduce this issue. Thanks for the feedback! -- Ryan • (comments) • 25-Feb-2009 18:31 PST
I am just starting to get into the user security stuff, so I have the admin user - admin, plus rebecca, rebeccac, and jamesw. I go to the jamwiki-war/en/Special:Roles , go to the section Search for users by login: and enter rebecca and hit search. Nothing comes up. (although same problem which ever user i search for except admin, which works).
When i go to jamwiki-war/en/Special:Listusers i get the following list:
  1. User:admin
  2. User:jamesw
  3. User:rebecca
  4. User:rebeccac
Thanks, that's helpful! I'll have to investigate further, hopefully tomorrow evening. -- Ryan • (comments) • 25-Feb-2009 22:21 PST
The fix mentioned below (changing sql.ansi.properties) solved this problem. It seems to be working fine now.
Thanks for the confirmation! I'm currently out of the country (but getting surprisingly good wireless!) so a 0.7.1 bugfix release may have to wait until I return, but I'll try to get any fixes that are ready rolled into a release by the end of the month. -- Ryan • (comments) • 08-Mar-2009 22:42 PDT